Compatibility

Apple iPhone running iOS 14.2 or later versions, and Android Phones running Android 10 or later versions are compatible with this software. Please make a request if using different smart phone models, which we will grant appropriate authorization.